Report generation timing out following .Net security updates

  • Following the installation of the .Net Core 3.1.22 and .Net 5.0.13 Security updates (KB5009193 and KB5009194), my application is no longer able to generate PDFs. I'm guessing it has something to do with one of these updates, but that's only because I'm out of other ideas.

    This application has been running perfectly for over two years now and is approaching end of life, so I really don't want to find a different solution for generating the PDFs. Is anyone else with those two updates having issues? Just in case it is of help, I get the following error:

    jsreport.Local.JsReportBinaryException: Error rendering report: instance has been daemonized and initialized successfully (pid: 16652)rendering has finished with errors:A critical error occurred while trying to execute the render command (2). Error while executing request to remote server. read ECONNRESET (1). caused by error (2):-> stackError: at onCriticalError (D:\snapshot\jsreport\node_modules\jsreport-cli\lib\commands\render.js:302:19) at D:\snapshot\jsreport\node_modules\jsreport-cli\lib\commands\render.js:256:14 at processTicksAndRejections (internal/process/task_queues.js:97:5)caused by error (1):-> meta =
    "headers":{"Accept":"application/json, text/plain, /","Content-Type":"application/json","User-Agent":"axios/0.19.2","Content-Length":3621},"transformRequest":[null],"transformResponse":[null],"timeout":0,"responseType":"stream","xsrfCookieName":"XSRF-TOKEN","xsrfHeaderName":"X-XSRF-TOKEN","maxContentLength":null,"httpsAgent":{"_events":{},"_eventsCount":2,"defaultPort":443,"protocol":"https:","options":{"rejectUnauthorized":false,"path":null},"requests":{},"sockets":{},"freeSockets":{},"keepAliveMsecs":1000,"keepAlive":false,"maxSockets":null,"maxFreeSockets":256,"maxCachedSessions":100,"_sessionCache":{"map":{},"list":[]}},"maxBodyLength":null},"code":"ECONNRESET"}-> stackError: Error while executing request to remote server at Client.render (D:\snapshot\jsreport\node_modules\jsreport-client\lib\client.js) at processTicksAndRejections (internal/process/task_queues.js:97:5)Request Error stack: Error: read ECONNRESET at TCP.onStreamRead (internal/stream_base_commons.js:205:27)

  • Could you please try the first cleanup as the following:

    stop the app
    kill all the jsreport/node.exe processes
    delete folder [user]/temp/jsreport
    start the app again

    I will try jsreport with the mentioned versions, if it can be a source of problems.

  • No luck with that. I also updated Visual Studio (running 2019) to the most recent version, did a pull of the code and rebuilt in both .Net core 3.1 and .Net 5 with the same result.

  • You get the same error also for the simple html report with some "hello world right" ?

  • I downloaded the example console app from Github and I am seeing the same issue, yes.

  • Ok thanks, I was just about to try that one. I will come back to you.

  • Quick update to that, I deleted the temp/jsreport folder and ran the test again and got a different error:

    29Remote Instance Error: Error: EPERM: operation not permitted, rename
    'C:\Users\MyName\AppData\Local\Temp\jsreport\compile\jsreport-2.9.0-SJEB3Pyev~chrome-oSCDt25i7' ->

    I appreciate the help so far.

  • I've tried to update .net and have no issues with the console example using jsreport.Binary 2.9.0 or 2.11.0.

    Could you try to download windows binary and render something from the console?

    jsreport.exe render --template.content=sometext.html --template.recipe=chrome-pdf --template.engine=handlebars --out=out.pdf

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.