HeadlessChrome error: ERROR: The requested object does not exist.

  • Hello, I have been using jsreports in a production environment with no problems until today. It seems that headless chrome is having issues, I tried changed the recipe to other types and I do not receive an error unless it's headless-chrome:

    2020-02-03T15:34:13.912Z - debug: Converting with chrome HeadlessChrome/76.0.3803.0 using dedicated-process strategy
    2020-02-03T15:34:14.186Z - debug: Running chrome with params {"marginTop":".5cm","marginRight":".5cm","marginBottom":"2cm","marginLeft":".5cm","margin":{"top":".5cm","right":".5cm","bottom":"2cm","left":".5cm"},"printBackground":true}
    ERROR: The requested object does not exist.

    Any advice?


  • Hm, haven't seen this error so far.

    Does it happen for all templates or just for a particular one?
    Are you able to replicate the issue on another environment?
    Are you running in a limited environment where the memory limitation could be a problem?

    There is a chance there is a bug in chrome that was fixed in later releases you may try to run

    npm i puppeteer@1.20.0 --save

  • This happens for all my templates on that machine.

    I cannot replicate the issue on the development environment...

    There definitely is enough memory (RAM, Storage) on the production machine.

    I tried updating puppeteer but it didn't help. Nothing has changed configuration wise here outside of potentially some kind of automatic update on the server.

    Very weird, I tried copying a fresh server folder and doing npm install, jsreport start and that didn't help me either.

    I guess I can try manually restarting the server tonight and see if that fixes it.

  • @MKuenzi Were you able to resolve this issue? We are experiencing the same exact issue, which was running fine all these years. Restarting the server did not help and so was curious to know if you ever had a solution. Appreciate your reply. Thanks in advance.

  • @vadnala I think this is when I ended up moving the jsreport server to Amazon EBS and it worked fine. So I never figured it out, I just moved to a new environment, I'm using Docker in conjunction with jsreport and deploying with EBS.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.