Unable to load templates in custom directory (jsreport version: 2.6.1 cli version: 2.1.1 jsreport-wkhtmltopdf version: 2.1.1)

  • I'm trying to start jsreport using command:
    jsreport --dataDirectory ~/projects/jsreport/reports/ start
    but the console outputs:
    2020-02-11T14:50:16.678Z - info: reporter initialized
    2020-02-11T14:50:39.368Z - debug: OData query on templates
    2020-02-11T14:50:39.375Z - debug: OData query on folders
    2020-02-11T14:50:39.377Z - debug: OData query on tags
    2020-02-11T14:50:39.380Z - debug: OData query on data
    2020-02-11T14:50:39.381Z - debug: OData query on assets
    2020-02-11T14:50:39.382Z - debug: OData query on scripts
    2020-02-11T14:50:39.392Z - debug: OData query on xlsxTemplates
    2020-02-11T14:50:39.394Z - debug: OData query on schedules
    2020-02-11T14:50:39.410Z - debug: OData query on settings
    Even going to http://localhost:5488/ there is only samples data. But inside ~/projects/jsreport/reports/ directory there are assets, templates, spripts, data, images, ... and so on.
    Previously I was using jsreport-cli@1.3.2 and jsreport@1.10.0 and it worked like a charm using same command jsreport --dataDirectory ~/projects/jsreport/reports/ start
    Are there any changes in running jsreport2x?

  • Please use this

    jsreport --extensions.fs-store.dataDirectory=~/projects/jsreport/reports/ start

  • Thank you so much, now it works!

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.