New users not working

  • Hello,

    I just tried adding a few new users (New Entity > user) to log in to jsreport, but none of them seem to be working. I keep getting returned to the login screen. I've tried setting different permissions for each one, but nothing seems to work. The only user ID I can use to log in is the "admin" account.

    Do you have any suggestions?

  • What jsreport version do you use?
    Is this your local jsreport instance or a remote one that can have a proxy or web server on the way?

  • I'm using v2.7.2. And this instance is running on an EC2 instance in trial mode.

  • Do you experience the same when running on local instance?

  • I just noticed that I also have v2.6.1 running in a similar EC2 instance and that one is working fine. So I don't think that it's an EC2 problem. But I'll try installing on a local instance to see if that make a difference and report back.

  • You can disregard this issue. I had made a change to create a custom login screen that required modifications to authentication.js. I was just copying an older version of this file from a previous installation, but it looks like it was updated since then and the old version was not compatible. I apologize for the confusion!

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.