Azure App Service deployment: Error while running sample report orders-main.

  • I get the following error while running the orders-main sample report in my azure deployment.

    "Error while executing user script. require of "https" module has been blocked. To be able to require custom modules you need to add to configuration { "allowLocalFilesAccess": true } or enable just specific module using { "extensions": { "scripts": { "allowedModules": ["https"] } }."

    I added the "allowLocalFilesAcces" application setting to the configuration for the App Service. After adding this setting the app is asking me to enter a password for every report I run.

    Thank you for your help
    Pedro Reinoso

  • Have you tried to F5 the app?
    What if you try to run with html recipe? Does it also ask for the password?

  • Jan,

    Yes, I refreshed the app (F5) several times. It still requires a password. Here is a summary of what I've found.

    • It appears that the issue is related to the chrome-pdf recipe. The problem does not happen when I change the recipe to "html".
    • Unfortunately we do need the chrome-pdf recipe for the application we are designing and building.
    • I noticed that all reports set to chrome-pdf are eventually set with a password in the "pdf-password" property by the environment.
    • I created a simple report template in my local VS Code environment and exported the zip file. Then I imported it into my azure jsreport deployment. Even this simple report is eventually set with a password in the properties, which in turn causes the app to prompt you with a password dialog box while running the report.
    • After I enter the password, the report renders fine. What am I missing? Thank you for your help.

  • Please try to check this template property. You may have a password filled here.
    I experienced some times that the proactive browser can automatically fill here a value without knowing.


  • Jan,
    I found the root of the problem. This behavior is apparently related to the MS Edge browser. Since I decided to save my password the first time I launched the app and logged in, every time I load a sample template the "pdf-password" property is automatically filled with the save password used in the login screen. Once I deleted the saved password from the profile I no longer experience the problem. By the way, I tested in Firefox and Chrome also. These two browsers do not present the problem.
    Thank you for your help.
    Pedro Reinoso

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.