Docker Web GUI broken in 2.10?

  • Hi I am deploying my jsreport server using docker and AWS Elastic Beanstalk and I am seeing this after updating to 2.10 in the Web GUI, which results in an infinite spinner:


    My Dockerfile looks like this:

    FROM jsreport/jsreport:2.9.0
    COPY ["data", "data"]
    COPY ["jsreport.config.json", "jsreport.config.json"]
    # we want to preserve the chrome version of 2.7.1 and just update the jsreport
    RUN npm install jsreport@2.10.0 && npm cache clean -f
    USER root
    CMD ["bash", "/app/"]
    EXPOSE 80

    Am I doing something wrong or is there an issue with jsreport?


  • Hi,

    I am not able to replicate this on this similar dockerfile

    FROM jsreport/jsreport:2.9.0
    RUN npm install jsreport@2.10.0 && npm cache clean -f
    USER root
    CMD ["bash", "/app/"]
    EXPOSE 5488

    Have you tried it in the private mode without browser cache?
    Can you try it without stored templates?
    Also please try to build the image with --no-cache

  • After a day of tinkering around with this I realize this is an issue I am running into with Amazon Elastic Beanstalk. I tried to do everything to invalidate the Dockerfile (I'm not pulling the image from a docker repository to avoid the additional complexity, I am simply uploading to EBS from my jsreport folder). I tried creating a new environment under my existing EBS application, that didn't work.

    The best solution seems to be to just start a new application up from scratch in EBS, which did work on the first try.

    Thanks Jan

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.