Trouble getting chrome-pdf to work after on-premise install

  • I've recently installed the on-premise version into an Amazon EC2 instance, following the steps outline here

    The step in which chrome is supposed to be installed doesnt seem to be picking up the installation as we are getting the error listed at the bottom. It appears to maybe be a linking / config issue but not quite sure what to try. Is there anything that might stand out as an easy adjustment to get jsreport to recognize the installation?

    wget -qO- | bash
    Error: Failed to launch chrome!
    /home/ec2-user/jsreportapp/node_modules/puppeteer/.local-chromium/linux-706915/chrome-linux/chrome: error while loading shared libraries: cannot open shared object file: No such file or directory
        at onClose (/home/ec2-user/jsreportapp/node_modules/puppeteer/lib/Launcher.js:348:14)
        at Interface.helper.addEventListener (/home/ec2-user/jsreportapp/node_modules/puppeteer/lib/Launcher.js:337:50)
        at emitNone (events.js:111:20)
        at Interface.emit (events.js:208:7)
        at Interface.close (readline.js:368:8)
        at Socket.onend (readline.js:147:10)
        at emitNone (events.js:111:20)
        at Socket.emit (events.js:208:7)
        at endReadableNT (_stream_readable.js:1064:12)
        at _combinedTickCallback (internal/process/next_tick.js:138:11)
        at process._tickCallback (internal/process/next_tick.js:180:9)

  • Does this help?

    sudo apt-get install -y libxtst6 libxss1

    for amazon linux /centos you may try

    sudo yum install

  • Hi - thanks for the response. Ive tried quite a few things but still receiving the same error. Here are some notes:

    [UPDATE] - solved with an additional command listed in another post below

    Here is my current package.json

      "name": "jsreport-server",
      "main": "server.js",
      "scripts": {
        "start": "node server",
        "jsreport": "jsreport"
      "jsreport": {
        "entryPoint": "server.js"
      "dependencies": {
        "archiver": "^5.3.0",
        "jsreport": "^2.11.0",
        "jsreport-phantom-pdf": "2.6.1",
        "jsreport-xlsx": "^2.5.0",
        "moment": "^2.29.1",
        "ncp": "^2.0.0",
        "request": "^2.88.2"

  • Oddly enough, I saw a couple recommendations to run the following command, and it actually solved the problem. Just wanted to share what worked for me.

    yum install libXScrnSaver

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.