An unhandled exception occurred while processing the request.

  • I am getting the following error when trying to compile the project:

    An unhandled exception occurred while processing the request.
    JsReportBinaryException: Error rendering report: instance has been daemonized and initialized successfully (pid: 11880)rendering has finished with errors:A critical error occurred while trying to execute the render command (2). net::ERR_ACCESS_DENIED at file:///C:/Users/Tunahan Hazretleri/AppData/Local/Temp/jsreport/autocleanup/e21967ee-dd26-4fef-ab8a-896832acb4dc-chrome-pdf.html (1). caused by error (2):-> stackError: at onCriticalError (D:\snapshot\jsreport\node_modules\jsreport-cli\lib\commands\render.js:302:19) at D:\snapshot\jsreport\node_modules\jsreport-cli\lib\commands\render.js:256:14 at processTicksAndRejections (internal/process/task_queues.js:97:5)caused by error (1):-> stackError: at Client.render (D:\snapshot\jsreport\node_modules\jsreport-client\lib\client.js) at processTicksAndRejections (internal/process/task_queues.js:97:5) at async startRender (D:\snapshot\jsreport\node_modules\jsreport-cli\lib\commands\render.js:319:24) at async D:\snapshot\jsreport\node_modules\jsreport-cli\lib\commands\render.js:226:22 at async Commander.executeCommand (D:\snapshot\jsreport\node_modules\jsreport-cli\lib\commander.js:242:22)Remote stack: Error: at navigate (D:\snapshot\jsreport\node_modules\puppeteer\lib\FrameManager.js:120:37) at processTicksAndRejections (internal/process/task_queues.js:97:5) at async FrameManager.navigateFrame (D:\snapshot\jsreport\node_modules\puppeteer\lib\FrameManager.js:94:17) at async Frame.goto (D:\snapshot\jsreport\node_modules\puppeteer\lib\FrameManager.js:406:12) at async Page.goto (D:\snapshot\jsreport\node_modules\puppeteer\lib\Page.js:675:12) at async D:\snapshot\jsreport\node_modules\jsreport-chrome-pdf\lib\conversion.js:134:5 at async D:\snapshot\jsreport\node_modules\jsreport-chrome-pdf\lib\conversion.js:301:22 -- ASYNC -- at Frame.<anonymous> (D:\snapshot\jsreport\node_modules\puppeteer\lib\helper.js:111:15) at Page.goto (D:\snapshot\jsreport\node_modules\puppeteer\lib\Page.js:675:49) at Page.<anonymous> (D:\snapshot\jsreport\node_modules\puppeteer\lib\helper.js:112:23) at D:\snapshot\jsreport\node_modules\jsreport-chrome-pdf\lib\conversion.js:134:16 at processTicksAndRejections (internal/process/task_queues.js:97:5) at async D:\snapshot\jsreport\node_modules\jsreport-chrome-pdf\lib\conversion.js:301:22
    jsreport.Local.Internal.LocalUtilityReportingService.RenderAsync(string requestString, CancellationToken ct)

    I tried to delete jsreport folder in Temp, then it worked but now this doesn't even work anymore. Also I havent D folder in my computer.

  • jsreport writes the generated HTML to the temp the first and afterward it uses chrome to read it and generate the pdf.
    For some reason, the access to the generated HTML in temp is blocked in your environment.

    Do you get this error for every HTML or only for something more complex?
    Do you run the app in the IIS?
    Don't you have some kind of extra antivirus running?

  • First of all thanks for replying. Yes it does this on every html page. I didn't get any such error on my first try. Although I did not change the code, I encountered such an error later. Yes I am running on IIS. I don't use antivirus.

  • Don't you have your app pool configured to use more than one worker process?

    Could you also try to run the app outside IIS to see if it works?

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.