Error when using Azure Blob Storage

  • Hello, I am using the Azure Blob Storage provider, but I am experiencing some errors every time I render a template (via the azure function starter kit). I put in an extra console.log within the main.js from the jsreport-azure-storage and it errors out when it tries to read a (what I presume not yet created) profile log.
    The path to the blob it errors out on:


    The error message:

    Executed 'Functions.HttpTrigger1' (Failed, Id=6f91cbf4-d071-4bda-a469-9c5facff5019, Duration=430ms)
    [2022-03-22T09:47:46.046Z] System.Private.CoreLib: Exception while executing function: Functions.HttpTrigger1. System.Private.CoreLib: node exited with code 1
     LanguageWorkerConsoleLog[error] Worker 491a75a9-e603-4636-916a-0dbd85d269d4 uncaught exception (learn more: ): RestError: The specified blob does not exist. RequestId:3fae6303-701e-0138-4ed1-3d120b000000 Time:2022-03-22T09:47:46.9694976Z     at new RestError (C:\Users\Flokkie\source\repos\jsreport-azure-functions-starter-kit\node_modules\@azure\core-http\dist\index.js:2390:28)     at handleErrorResponse (C:\Users\Flokkie\source\repos\jsreport-azure-functions-starter-kit\node_modules\@azure\core-http\dist\index.js:3274:17)     at C:\Users\Flokkie\source\repos\jsreport-azure-functions-starter-kit\node_modules\@azure\core-http\dist\index.js:3210:18     at processTicksAndRejections (node:internal/process/task_queues:96:5).

    Can anyone tell me where I might be doing something wrong?

  • Hi, thank you for the bug report. I will try to replicate it...
    Have you tried it with the latest jsreport 3.4.1 ?

  • Yes I have tried it with the latest version.

  • Thank you. I was able to replicate the problem. We have the fix ready and will ship it with the next jsreport update 3.5.0

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.