Can't get past step "jsreport configure" - An error occurred while trying to execute "configure" command (2). Cannot read properties of undefined.

  • Just discovered "jsreport" today. I followed instructions as shown on
    This is a Windows 10 machine. I currently have node 16.14.0.
    All commands up to "jsreport init" this look like they completed properly. I run into this error when I finish answering the questions during the "jsreport configure" command. I tried answering both "y" and "N" to the question "Do you want to enable authentication in web server?", just to see if I could sidestep a potential issue related to that, but I got the same result with both "y" and "N" attempts.
    When I finish answering the questions asked at execution of the "jsreport configure" command, I get this error:

    An error ocurred while trying to execute "configure" command (2). Cannot read properties of undefined (reading 'indexOf') (1).
    caused by error (2):
    -> stack
    at startCLI (C:\Users\larry\jsreportapp\node_modules@jsreport\jsreport-cli\lib\commander\startCommand.js:127:19)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async startCommand (C:\Users\larry\jsreportapp\node_modules@jsreport\jsreport-cli\lib\commander\startCommand.js:67:5)
    at async startProcessing (C:\Users\larry\jsreportapp\node_modules@jsreport\jsreport-cli\lib\commander\startProcessing.js:195:3)
    caused by error (1):
    -> stack
    at Object.when (C:\Users\larry\jsreportapp\node_modules@jsreport\jsreport-cli\lib\commands\configure.js:148:58)
    at C:\Users\larry\jsreportapp\node_modules\run-async\index.js:49:25
    at new Promise (<anonymous>)
    at C:\Users\larry\jsreportapp\node_modules\run-async\index.js:26:19
    at C:\Users\larry\jsreportapp\node_modules\inquirer\lib\ui\prompt.js:140:32
    at Observable._subscribe (C:\Users\larry\jsreportapp\node_modules\rxjs\dist\cjs\internal\observable\defer.js:8:31)
    at Observable._trySubscribe (C:\Users\larry\jsreportapp\node_modules\rxjs\dist\cjs\internal\Observable.js:41:25)
    at C:\Users\larry\jsreportapp\node_modules\rxjs\dist\cjs\internal\Observable.js:35:31
    at Object.errorContext (C:\Users\larry\jsreportapp\node_modules\rxjs\dist\cjs\internal\util\errorContext.js:22:9)
    at Observable.subscribe (C:\Users\larry\jsreportapp\node_modules\rxjs\dist\cjs\internal\Observable.js:26:24)

    I have no idea where to start with this error.

  • I apologize, this was actually our bug which we have just fixed in the 3.6.2

    Please delete the current app folder and reinstall

    npm i uninstall -g @jsreport/jsreport-cli
    npm i -g @jsreport/jsreport-cli
    jsreport init
    jsreport configure

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.