JS-report Studio - Reports menu item from settings menu vs GET//odata/reports

  • Hi!
    Choosing the "reports menu" item from settings menu in JS report studio , does not show any data in the web browser, but the api call

    GET http://x.0.y.z:5488/odata/reports for the same user gets, what I believe is the same information that should be shown above.

    Am I missing something or is this a known issue?


  • Hi Micke,
    could you please reload the studio with F5 and check the reports page afterwards? It would help us where to search for the bug.

  • Thanks for the very fast response!
    I am using macOs and doing F5 does not seems to refresh the reports page in neither Firefox nor Safari. I tried to clear all caches in Safari with no difference in response

  • Ok, thank you. We will look into it.

  • I found some time to check this out, but cannot replicate it so far. At least on my win chrome/firefox.

    I've tried to create some reports using a schedule for admin user. I see them in the reports UI.
    I've also tried to create a new user and generate reports using API call

      "template": {
        "name": "b"
      "options": {
        "reports": { "save": true }

    Reports generated this way are also visible in the UI for the authenticated user in request as well as for the admin user.

    Could you please try to describe for me what steps did you follow to get into the described situation?
    Or if you use the default fs store, could you zip your data folder and send it to me?

    Thank you

  • Hi again! I am using Postgres store and fs store. I did an export, reconfigure my dev server to use fs store and imported the setup. Now it works, so the issue is definitely connected to Postgres store!

    Please note that scheduling does not work in Postgres store neither, so I guess I should use fs store until the bugs are fixed in Postgres store. One issue that seem to be the same regardless of store is that I cannot schedule reports using the time fields (grayed out and cannot be filled), but the expression field is working but is not as user friendly. Is this a know issue

  • Great, thank you. I will try it out with postgres.

    Regarding setting the time. There is github issue which you can subscribe and get notification when it gets fixed.

  • Thanks Jan!
    Short-term I have no issue to use fs-store, however long-term I am interested to see that postgres-store works as well

  • The bugs related to postgres should be now fixed in jsreport-postgres-store@0.1.7.

  • Ok, great thanks, I will try it out very soon

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.