JSReport instance export file generates empty files with size 0 KB

  • Hello there,
    When I export a report from an instance running in my local PC, I get the export.zip file. However, all the files are empty with size 0 KB. This is really weird, I have done this task docents of times. I even tried exporting a previous report I exported a while back with no success. The export package ZIP file is created with all the files and folders. But all the files are empty! Size 0 KB for all files. I am running jsreport 2.9.0 using VS Code.

    Thank you for your help

    Pedro Reinoso

  • What is your nodejs version? jsreport v2 export works just with node <=14

  • I am running Node.js v16.19.1 in my local PC. How do I upgrade JSReport to a higher version?
    Pedro Reinoso

  • To upgrade into v3, you should do the following.

    Backup app and data.

    Update package.json file and set jsreport version to 3.13.0. Then type npm install
    To start jsreport you can use the same node server.js.

    See the v3 announcement to see what is changed

  • I followed the steps shown in the link below.


    However, the app folder is completely empty after running the installation command:
    npm i -g @jsreport/jsreport-cli

    I get the following message:
    I am using VS Code. The node.js version is v18.17.1


  • Please continue with the next steps in the docs...
    You need to call the next step jsreport init that will actually install jsreport.

  • I resolved the issue of exporting empty files by installing a compatible version of Node.js
    However, I run into problems upgrading the app because the command line was installing Node.js in a global location. Our web app is using yet a different version of Node.js. So, I need to figure out how to install more than one version of Node.js in a single PC.

    Thank you for your help.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.