Can't move files since utilizing azure-storage persistence

  • I recently updated my kubernetes deployed docker container of jsreport to use an azure-storage container for persistent storage. It effectively loads and saves files to the storage account as I create them. However, when ever I move a file in the portal to a folder, or move a folder into another folder, it hangs and crashes the instance completely. I noticed in the storage container, it creates a ~.tran folder and file. However, when I restart the instance, it does not load from the ~.tran folder, and that folder remains. While that folder exists, I can't run any templates or create new ones, let alone move any. Once I remove the folder and restart, I can create and run templates again, but if I try to move any to a folder, the problem repeats itself. Please help! Persisting with azure is making jsreport unusable.

  • We are checking the regression bug in the azure storage fs persistence. We keep you updated today or tomorrow.

  • @admin thank you!!! Appreciate you looking into this.

  • I've published the @jsreport/jsreport-fs-store-azure-storage-persistence@4.0.1
    Please update it and try again.

    If you use the jsreport official full image, you will need to inherit your own image and update this dependency
    We will update the official image during the next days.

    If this doesn't help please let me know what version of jsreport you use.
    I've tried the change with an empty workspace, where jsreport automatically creates the samples and then I've moved folders. This worked well with the fix.

    I apologize for the inconvenience.

  • Upgrading the package worked! Thank you so much. I'll update this thread if I notice any related bugs. Appreciate this.

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.