How can i solve no sandbox error when export jsreport?

  • Using redhat server, I got error msg when export jsreport. Failed to launch chrome!\n[0412/] locale_file_path.empty() for locale \n[0412/] No usable sandbox! Update your kernel...
    But i use config as suggestions in similar forum like this.

      "httpPort": 5488,
      "store": {
        "provider": "fs"
      "blobStorage": {
        "provider": "fs"
      "logger": {
        "console": {
          "transport": "console",
          "level": "debug"
        "file": {
          "transport": "file",
          "level": "info",
          "filename": "logs/reporter.log"
        "error": {
          "transport": "file",
          "level": "error",
          "filename": "logs/error.log"
      "trustUserCode": true,
      "reportTimeout": 60000,
      "workers": {
        "numberOfWorkers": 2
      "chrome": {
        "launchOptions": {
          "args": ["--no-sandbox"]
      "extensions": {
        "authentication": {
          "cookieSession": {},
          "admin": {
            "username": "admin",
            "password": "password"
          "enabled": false
        "sample-template": {
          "createSamples": true

    It's not working on my environment. how can i do?

  • Have you tried the following tutorial to install proper chrome redhat dependencies?

  • yes. i tried from tutorial to install proper chrome red-hat dependencies and same error still occurred.

  • What RedHat version are you on? Are you able to update the OS?

  • Here is the Redhat version and GLIBC version.

    Red Hat Enterprise Linux Server release 7.5 (Maipo)
    ldd (GNU libc) 2.17

    i can't able to update the OS. should i reinstall the jsreport downgrade version? now jsreport only support on nodejs >= 18.5 version?

  • I've tested the installation instructions only on the mentioned
    Red Hat Enterprise Linux 9.3
    Red Hat Enterprise Linux 8.7
    So the latest chrome dep seems to have issues on your older OS.
    The latest jsreport supports only nodejs >=18.5

    You can try to downgrade the jsreport if it will work for you.
    Or try docker if you are able to set it up on Red Hat 7.5

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.