Error while executing templating engine. Missing helper: "toJS"

  • in the playground the code works in my other PC same code also works, but here i tried to set up js server and i did import the files but the error "Error while executing templating engine. Missing helper: "toJS"" keeps showing up and another thing the template icon in the playground and the other PC js server contains the word PDF but not on this device which has the problem i tried to reinstall js report also node js and the problem is not solved ????

  • You may be on an older version of jsreport.
    Try to completely delete jsreport app folder, and also run

    npm uninstall -g jsreport-cli
    npm uninstall -g @jsreport/jsreport-cli

    And then follow again the installation instructions

    npm install @jsreport/jsreport-cli -g
    mkdir jsreportapp
    cd jsreportapp
    jsreport init
    jsreport configure
    jsreport start

  • as usual you solved it, thank you.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.