Mabbox-gl failed to work in docker container on AWS EC2

  • Hi There, we have a project which have following jsreport version:

    "jsreport": "^2.11.0",
    "jsreport-chrome-pdf": "=1.10.0",

    Which have same issue as the one reported here:
    What we have done here is using an override for the puppeteer:

    "overrides": {
        "jsreport": {
            "puppeteer": "=22.0.0"

    This approach works fine locally, but we decide to deploy this project to an docker container and hosted in AWS EC2 instance and the pdf generating for a chart using mapbox-gl now failing.

    we tried to build docker image and test it locally and using following config:

    'chrome-pdf': {
        'launchOptions': {
             'defaultViewport': null,
             'args': ['--no-sandbox', '--window-size=1800,1350', '--use-angle=swiftshader','--use-gl=angle','--in-process-gpu']
         'strategy': 'chrome-pool',
        'allowLocalFilesAccess': true,
        'numberOfWorkers': 3

    This makes it working in local docker container, but still not working in the EC2. Do you have any clue about this? Thanks in advanc!

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.