Issue when applying licence on jsreport docker throught Rancher

  • Hi Jsreport team!

    First of all, happy new year!

    So, as mentioned in the title ,we (finaly) bought a licence and wanted to apply it right away, following the FAQ it seemed logical to use the environnement variable approach.

    But it didn't work :( and we keep having the Trial licence messagewhen opening jsreport (after rebooting the docker, or even after reinstall it).

    Could it be something amiss on our side?

    Thanks in advance!!

  • Hi, happy new year to you as well.

    Do you use your custom docker image or the official one? How do you apply the environment variables?

    This works for me as expected:

    docker run -p 5488:5488 -e "license-key=xxx" jsreport/jsreport

  • Hi Jan!

    We do use the official image (1.9.2-full), however the environnement variable is passed through a form in rancher,
    do you happen to have encounter this kind of setup?

  • Something we didn't try, in the FAQ you tell us to remove all space wraping the licence, do we have to remove the -as well?

  • No, that should stay there. The boot would fail if the provided license key is not valid. I guess the license key is not received in jsreport at all based on the "Trial licence message" .

    Do you use also jsreport configuration file? You could put the license key there as well.

    I try to check the rancher if there are some tricks for applying environment variables.

  • Unfortunately we cannot use the config file as we do not have volumes to put it in. so environnemnet variable is really our sole option in this context :/
    After checking, the rancher outpout the licence as in your example. We try to re create from scratch the docker instance to see if something change.

  • I've been trying to use the licence on a local docker instance (passing key as env. var.) without rancher, upon verifying the licence I end up with the following :

    docker run -p 5488:5488 -e "license-key=X-X-X-X" jsreport/jsreport:1.9.2-full
    info: The licensing server was not reachable during instance startup. The instance now runs in the enterprise mode.

    so here as well it seems we have issue contacting the server which is quite strange :/

  • This is different scenario. Your container likely cannot reach internet to verify the license key. So it assumes it is valid and boot normally.
    When rancher scenario doesn't get the license key from env at all the most likely.

    I'm trying to run my local rancher to test it, so far having some issues with adding host...

  • So I've spent couple of hours trying to start up my rancher. They should really write to output a message "Hey man, you have incompatible version of docker" ... Anyway finally it runs for me.

    I was able to start default jsreport container. Verified it is running fine by using ip adress and port 5488.
    Then I used rancher upgrade and add license-key environment variable.
    Rancher created new container which I verified again and it is correctly using the enterprise jsreport license.

    Now I'm not sure what you are doing wrong. Can you check the screenshot and let me know if you have something differently?


  • there is few difference, I wouldn't think this does make the trick but could you confirm it please?
    here is what we have :
    0_1514902014662_Rancher 2018-01-02 15-00-51.png

    in green areas are what is different between our side and yours

  • The container with the Interactive&TTY console was not running for me at all for some reason.
    But It is likely not the problematic thing.

    Don't you have a space after the license-key string? Can you try to run another container with just license key environment variable just like I have it?

  • will try that first and return asap :)

  • Sorry for the delay, but I come back with a good new! IT WORKS!

    The culprit was simply that Interactive&TTY console setting it to none solved everything!!
    Might be interesting to add this information to the documentation?

    Thanks a lot for your help!!

    [Edit] : now that I remember we add to add an extra npm startto make it work with the Interactive&TTY console, it was no longer needed after removing it!

  • Thank you for the info. I'm happy that my 3 hours of rancher installation wasn't a waste. :)

    I've updated the jsreport download section to give this hint for Rancher users.


Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.