JSreport asks for authentication when I run a report

  • Hello,

    I got JSreport running using kubernetes and try to run a report. JS report is configured with simple authentication enabled so that I can login using the login screen. When I run a report the application asks for a username and password again.
    I tried to enter my username and password again but this does not get accepted.

    Does anyone have any ideas?

    Thanks in advance,


  • I also see this in the logs:

    2018-05-01T10:19:14.683Z - info: Rendering template {shortid:ryf6T9r6z, recipe:phantom-pdf, engine:handlebars, preview:true} requestId=29
    (node:10) Warning: a promise was created in a handler at usr/src/app/node_modules/jsreport-authentication/lib/authentication.js:446:7 but was not returned from it, see http://goo.gl/rRqMUw
    at Function.Promise.cast (/usr/src/app/node_modules/bluebird/js/release/promise.js:196:13)

  • How do you run the report. With API call or by click "Run" in jsreport studio?

    Can you share how you configure the authentication?

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.