Keep alive problem

  • Is there any config option to keep it alive while using jsreport-core?

    this is my config as of now

    const config = {
    phantom: {
    strategy: "phantom-server"
    templatingEngines: {
    numberOfWorkers: 1,
    strategy: "in-process"
    licenseKey: process.env.JSREPORT_LICENSE

    but it keeps falling asleep after like an hours or so and the initial request then takes quite long

  • jsreport is not falling a sleep itself.
    don't you use some process manager which does this? like IIS?

  • It is on azure as web app. Could it be iisnode problem?

    <?xml version="1.0" encoding="utf-8"?>
    <add name="iisnode" path="app.js" verb="" modules="iisnode"/>
    <rule name="DynamicContent">
    <match url="/
    " />
    <action type="Rewrite" url="app.js"/>

    Sorry, not sure how to format code here x_ x

  • ...use markdown formatting...

    Yes nothing to do with jsreport.
    It is well known IIS behavior that it after some idle time recycles application pool and put it to sleep.
    Search for azure web app "always on" option.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.