How to turn off preview mode?

  • Preview mode says it will send my documents to your office account to be previewed. How do I turn this off?

  • administrators

    hi! is the option previewInExcelOnline: false mentioned here not working?

  • @bjrmatos does that work for all document types? I'm not using excel documents. I'm using docxtemplater which is giving me a docx and then I'm using unoconv to turn that into a PDF. I'm pretty sure what I'm looking at is a PDF in the preview. I will try your suggestion, though.

  • administrators

    ah ok, i assumed the most common case of office documents (which is excel).

    if you are using docxtemplater + unoconv then nothing is send to our server, because what you see in the preview is just a PDF file served from your local.

    however if you are using docxtemplater alone the preview is a word file that is send to our server because we need that to server the file to office online, in that case you can disable it with { "extensions": { "docxtemplater": { "previewInWordOnline": false } } } (it is not mentioned in docs.. we will add it)

  • Oh! Ok, I didn't realize that. Just assumed it was sending it to office online. Thanks.

  • Can we also update the docs to include the setting for the docx recipe please? Thank you in advance

  • @manemal Every office-based extension now links general documentation for configuring the preview
    Note it is valid for jsreport 2.6.0

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.