Unable to save report

  • I'm having trouble saving a new template (and make changes to some old templates) in the JSReport Studio. It continues to prompt me for username and password and fails. Am I doing something wrong? Known issue?

  • administrators

    hi! when it started to happen? did you do something that maybe trigger it? (like updating jsreport or restarting it, or maybe changing the configuration) i just remember one similar case when this was happening, but it was resolved but refreshing browser cache, deleting cookies and restarting jsreport.

  • I don't believe that there is anything coincidental that triggered it. I haven't been into JSReport Studio in a while (this is the hosted version, not local). I can certainly refresh cache, etc. and try that. I did try a different browser that I don't believe I have ever used to access JSReport Studio and I'm seeing the same thing.

  • administrators

    ah ok, so this is jsreportonline, right? hmm if it does not get fixed by refreshing browser cache, share with me your tenant name (https://[tenant-name].jsreportonline.net/) and i will try to check what is happening with your account.

  • Correct on the jsreportonline. Tenant name is 149photos

  • administrators

    hi, sorry for the wait, i just tested the authentication with your tenant and i can't replicate the issue, i don't see the authentication prompt. maybe the issue is gone by refreshing the browser cache, and cookies. i'm almost sure that it will be the case, but let me know how it goes.

  • I've tried clearing the cache and cookies, and even tried logging in from a new virtual machine and I get the same results. Can you try these specific steps?

    1. Clone the template "NewUserReport"
    2. Rename the cloned report to "FullUserReport"
    3. Try to save it.

    I get prompted for user credentials. I'm using the same credentials that I use from the jsreport-client library (and to login to the online site), and it just keeps asking me for more credentials and ultimately fails.

  • I tried the mentioned steps with your account and it works.
    Don't you run behind some kind of proxy?
    What browser/version do you use?

  • I'm not behind a proxy.

    I'm using Chrome Version 76.0.3809.132 on Windows 10.

    Could this be a login issue? i.e. different login for API vs. online editting? Can you PM on the credentials that you're using for your testing?

  • administrators

    Could this be a login issue?

    hmm i don't think that is be the problem. it will be weird that the user credentials are the problem.

    different login for API vs. online editting?

    i see that you have a "sails_user" so i guess this is the user that you use for your http API calls, so the other user gordon@149photos.com is the one that you use for the web login and for template editing, right? maybe something to try is that you try to login with the sails_user and try to save a template and see if you have the same error.

    i would like to see the chrome console that you have when trying to save the template, maybe there are some errors there, also it will be great if you can inspect in chrome the request that was done to save the template, basically i would like to see the details of the request that is showing the prompt (headers, body, response). maybe you can send some screenshoots like the following, or event better copy the information from there and paste it here

    0_1568132880249_Captura de pantalla 2019-09-10 a la(s) 11.23.34 a. m..png

    0_1568132898139_Captura de pantalla 2019-09-10 a la(s) 11.23.50 a. m..png

    0_1568132907944_Captura de pantalla 2019-09-10 a la(s) 11.24.01 a. m..png

    PD: to upload images here, first click the blue button "Reply" and the drag and drop images in the new textbox that appears

  • The problem is I was logged in as sails_user and not the other one. I think I'm good now.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.