NPM install error in version 1.8.2

  • Clean install of JSReport 1.8.2 gives phantom JS error.

    phantomjs@1.9.15 install C:\Repos\Netwealth.jsReport\Netwealth.jsReport\Netwealth.JSReport\node_modules\phantom-workers\node_modules\phantomjs
    node install.js

    npm[16172]: c:\ws\src\ Assertion args[1]->IsString()' failed. 1: 00007FF7B846C6AA v8::internal::GCIdleTimeHandler::GCIdleTimeHandler+4506 2: 00007FF7B8447416 node::MakeCallback+4534 3: 00007FF7B84474CF node::MakeCallback+4719 4: 00007FF7B841B7C0 node::DecodeWrite+13120 5: 00007FF7B8974382 std::vector<v8::internal::compiler::MoveOperands * __ptr64,v8::internal::ZoneAllocator<v8::internal::compiler::MoveOperands * __ptr64> >::_Umove+79442 6: 00007FF7B89754E9 std::vector<v8::internal::compiler::MoveOperands * __ptr64,v8::internal::ZoneAllocator<v8::internal::compiler::MoveOperands * __ptr64> >::_Umove+83897 7: 00007FF7B897482C std::vector<v8::internal::compiler::MoveOperands * __ptr64,v8::internal::ZoneAllocator<v8::internal::compiler::MoveOperands * __ptr64> >::_Umove+80636 8: 00007FF7B897474B std::vector<v8::internal::compiler::MoveOperands * __ptr64,v8::internal::ZoneAllocator<v8::internal::compiler::MoveOperands * __ptr64> >::_Umove+80411 9: 00000175DB3DC5C1 npm WARN react-copy-to-clipboard@4.3.0 requires a peer of react@^0.14 || ^15 but none is installed. You must install peer dependencies yourself. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.3 (node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) npm WARN optional SKIPPING OPTIONAL DEPENDENCY: phantomjs@1.9.15 (node_modules\phantom-workers\node_modules\phantomjs): npm WARN optional SKIPPING OPTIONAL DEPENDENCY: phantomjs@1.9.15 install:node install.js`
    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 134

    added 1 package from 6 contributors, removed 7 packages, updated 14 packages and audited 5653 packages in 8.699s
    found 470 vulnerabilities (62 low, 214 moderate, 192 high, 2 critical)
    run npm audit fix to fix them, or npm audit for details

  • administrators

    hmm i never saw this error, i think jsreport 1.8.x contains an older version of phantomjs which does not work with latest versions of node.js? what node.js version are you using it? i did a quick a search of the error message you have and it seems like some dependency problem, you can check here for details, maybe you can try some of the solutions described there.

  • Hi. Thanks for the response. We're using node v10.16.0. Could you let us know which version of node you had installed when you did your npm install and we'll try the same? We'll also review the solutions you've posted.

  • administrators

    i can't run templates with phantomjs on my local because i'm using mac OS version that is not compatible with phantomjs anymore but at the installation step i don't see any error when using node 8.16.0

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.