[V3] Report timeout azure app service

  • Hi,
    I'm running jsreport 3.0.1-full on azure app service with linux, but I get a timeout when generating Pdf documents.
    I have tried to make empty documents and tried the samples that comes with jsreport.
    This does work in version 2.11.0. Is there something that I'm missing in the setup to be able to run version 3.0.1?


    Log message:

    Report timeout
    Error: Report timeout
    at Timeout._onTimeout (/app/node_modules/@jsreport/advanced-workers/lib/threadWorker.js:41:23)
    at listOnTimeout (node:internal/timers:557:17)
    at processTimers (node:internal/timers:500:7)

    Azure App Service:



  • Thank you for reporting the problem. We will check whats is going on with the full image and come back.

    The default one jsreport/jsreport:3.0.1 should work. I was testing it recently when updating the web app tutorial

  • The jsreport/jsreport:3.1.1-full now works in azure app service properly.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.