Chrome-pdf has stopped showing highcharts

  • We haven't made any changes and it just stopped working the 31th October, it worked on the 30th October and before.
    Do you have any idea of why this could be, if I change the recipe to html-with-browser-client, then it shows the highcharts

    I have tried this example and it works with jsreport version 3.13.1
    I have added it to our jsreport instance and it doesn't show the graphs.

    Do you have any idea why it have stopped working?
    Any suggestions to how we can fix it, apart from doing an update to the newest version of jsReport.

    We use an old version of jsReport 2.10.0
    We have these extensions:
    assets: 1.7.0
    authentication: 2.6.0
    authorization: 2.4.0
    base: 2.0.2
    browser-client: 2.2.2
    child-templates: 1.4.0
    chrome-pdf: 1.9.0
    cli: 2.2.5
    data: 2.4.0
    debug: 2.1.3
    docx: 2.8.0
    ejs: 2.2.0
    electron-pdf: 3.2.0
    express: 2.8.0
    fop-pdf: 2.2.0
    freeze: 2.0.0
    fs-store: 2.9.0
    fs-store-aws-s3-persistence: 1.4.0
    fs-store-aws-sns-sync: 1.2.1
    fs-store-azure-sb-sync: 1.1.0
    fs-store-azure-storage-persistence: 1.2.0
    handlebars: 2.1.0
    html-embedded-in-docx: 2.2.0
    html-to-text: 2.1.0
    html-to-xlsx: 2.8.0
    import-export: 2.1.0
    jsrender: 2.1.1
    licensing: 2.2.3
    mongodb-store: 1.3.3
    pdf-utils: 1.9.0
    phantom-image: 2.1.0
    phantom-pdf: 2.6.0
    pptx: 0.7.0
    public-templates: 2.2.0
    pug: 3.1.0
    reports: 2.5.0
    resources: 2.1.0
    sample-template: 2.6.0
    scripts: 2.6.0
    static-pdf: 0.4.0
    studio: 2.10.1
    studio-theme-dark: 0.3.0
    tags: 2.5.0
    templates: 2.4.0
    text: 2.0.0
    version-control: 1.5.1
    wkhtmltopdf: 2.3.0
    xlsx: 2.5.0

  • I have found a solution for it.
    Highcharts had a new release on the 30th October and after that it didn't work so instead of linking to their newest version I'm now linking to the a specific version.


    and now

  • Thanks for this.
    I noticed the same on a report we haven't had time to migrate to jsReport 3.
    Your solution worked, but I moved the report to our v3 server instead. This works with HighCharts 11.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.