error in all pptx templates in jsreport studio

  • Hello,

    This morning all our templates pptx report an error when pressing "preview" in jsreport studio in the browser. These templates were previously working correctly and no changes were made. The "run" in the studio also doesn't work. What's interesting is that those templates render just fine when using API. Also in the studio, I have other templates using docx helper and those preview and run correctly. The error reported in the preview pane is :

    Cannot read properties of undefined (reading 'error').

    It is display using dark grey on black so it's barely visible:


    but I can read it when I highlight it:


  • We were enabling a gzip compression on a web server that is hosting temporary office files for preview. However, that should have no impact. I see no problems when previewing pptx.

    Does the same also happen for the sample pptx like this one?

    What jsreport version do you use? Are you behind some proxy?

  • Hi @admin, no, I'm not behind a proxy. Your sample pptx previews fine, but none of my pptx files work.
    jsreportonline version: 3.13.2
    jsreport version: 3.13.0

    I tried another machine, another location (home vs work), same effect. I tried reuploading, but no change. Like I said, templates that used to work in preview/run now don't without changes. They all still work when rendered using API though.

  • Thank you. We've misconfigured the max body size for uploads of the office reports. This should be now fixed. I apologize for the inconvenience.

  • Hi @admin, it works now. Thanks for the help.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.