Stak - Error: Command failed

  • I am getting this strange error when trying to generate a report from C# API or directly from the jsReport Studio from the same json file.

    Stak - Error: Command failed: C:\Users\USER\AppData\Local\Temp\jsreport\compile\jsreport-1.10.0-rJLPefJIG\phantomjs.exe --ignore-ssl-errors=yes --web-security=false --ssl-protocol=any C:\Users\USER\AppData\Local\Temp\jsreport\compile\jsreport-1.10.0-rJLPefJIG\standaloneScript.js C:\Users\USER\AppData\Local\Temp\jsreport\4d8dd9c0-204e-11e8-9c1d-fda1dac61bccsettings.html
    at ChildProcess.exithandler (child_process.js:214:12)
    at emitTwo (events.js:87:13)
    at ChildProcess.emit (events.js:172:7)
    at maybeClose (internal/child_process.js:854:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:222:5)

    I have a long complex report, with around 50 charts and all has been running well for a long time. The error occurs when I upgrade from Highcharts 5.0.7 to 6.0.7. I have checked the json and it is fine. I have tried running the same js/html (replaced handlebars syntax with razor) in an mvc app and its running fine (so no issue with highcharts). If I change the highcharts version back to 5.0.7, everything is fine (which is the simplest solution).

    I have tried to find the specific charts that may be causing the issue, but it seems to be multiple charts, and can't find any specific reason for this behaviour.
    Is the error pointing to something, that can be fixed?

  • administrators

    hi, hmm does the error happens too if you just try to render a simple chart with Highcharts 6 + phantom? maybe new version of Highcharts is using new standards (some canvas api or svg) that does not play well with phantom 1.9.8 (which is the default version that comes in jsreport.exe).

    if you really need to update Highcharts maybe you can also try to use phantom2 in your template, probably Highcharts6 will work there. to use phantom2 install and update your template recipe to use phantom2 version

  • Thank you.

    Yes, jsreport.Binary.Ph2 seems to work perfectly with Highcharts 6.0.7.

    A simple chart in Highcharts 6 seem to be working fine with with phantom 1.9.8. One of the charts causing the error was a stacked column chart. I did not play much with the chart options, so not sure what was really causing the issue.

    Anyway with some modification and setting the zoom to 0.75, jsreport.Binary.Ph2 is working great.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.