unhandled win32 exception

  • I can access jsreport using iisnode at localhost, but I get an unhandled win32 exception in w3wp.exe that crashes the app pool. I have set the applicationpool to enable 32 bit applications. The iisnode sample apps do not generate this exception when installed, but they do generate this exception after installing jsreport. The exception appears to be an access violation. Error information: Exception code: 0xc0000005 Faulting application path: C:\WINDOWS\SysWOW64\inetsrv\w3wp.exe Faulting module path: C:\WINDOWS\system32\inetsrv\iiscore.dll

  • administrators

    hi! long time since i hear about iisnode.. i'm not even sure if it still works in latest jsreport version (1.10.0) and we can't afford taking the time to test every new jsreport release against iisnode because it requires too much of our time. iisnode is buggy, we tried to keep up the support once but found different issues and inconsistencies compared to the normal nodejs. since iisnode has not been updated since 2016 and has many bugs i will recommend you to try to start your jsreport server with other solutions like pm2, forever, or normal windows services. your error description sounds like something is still missing to configure, the sample apps of iisnode unfortunately can not test every server scenario, but remember that even if iisnode is configured right we have not tested that latest jsreport version works in iisnode. however if you are able to find the root issue of this problem and the fix is easy for us to maintain and implement, then we can think in add it

  • Thank you, I appreciate your quick response. You might want to take the installation instructions off your blog (https://jsreport.net/blog/jsreport-hosting-options-on-windows)

  • administrators

    thanks, let's see.. that blog post is really old, so perhaps we need to go over all blog posts and update them to explicitly mark if it works or not in latest version or that it worked until some version.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.