Timeout error

  • Hi,
    I am running into this timeout error with jsreport version 2.1.1 and recipe - chrome-pdf.
    I am trying to understand at what point it throws this error.. while executing beforeRender or after.

    Thanks for any insights,

    2018-07-09T20:31:31.381Z - info: Starting rendering request 1 (user: null)
    2018-07-09T20:31:31.383Z - debug: Inline data specified.
    2018-07-09T20:31:31.383Z - debug: Resources not defined for this template.
    2018-07-09T20:31:31.386Z - debug: Executing script QuarterlyDetails
    2018-07-09T20:31:31.383Z - info: Rendering template { name: QuarterlyDetails, recipe: chrome-pdf, engine: handlebars, preview: false }
    2018-07-09T20:32:11.419Z - warn: Error when processing render request Timeout Error: Timeout
        at Timeout._onTimeout (C:\ifolder\iroot\jsReport2-0709\node_modules\script-manager\lib\manager-servers.js:137:23)
        at ontimeout (timers.js:498:11)
        at Timer.unrefdHandle (timers.js:611:5)
    From previous event:
        at Reporter.executeScript (C:\ifolder\iroot\jsReport2-0709\node_modules\jsreport-core\lib\reporter.js:266:47)
        at Scripts._executeScript (C:\ifolder\iroot\jsReport2-0709\node_modules\jsreport-scripts\lib\scripts.js:103:38)
        at <anonymous>
    2018-07-09T20:32:11.422Z - warn: Error during processing request at http://localhost:3000/reporting/api/report

  • administrators

    hi! so far it looks like it timeout after rendering, do you have some afterRender function in QuarterlyDetails script? if you can not figure it out and if you can share the template and the script i can try to run it on my local machine and tell why it timesout.

  • No afterRender function but I am merging 3 other templates with it.
    It got resolved in a weird way. If I run npm install and build-deploy all from command prompt rather than jetBrains IDE, it worked and no more timeout errors.

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.