Chrome recipies no longer works

  • Today my Chrome-PDF reports stoped working. They work fine if I switch to HTML rendering.

    I run jsreport from a local Docker image while developing. Does the local Chrome client influence the rendering, or is everything done with Puppeteer from inside of the container?

    The last message in the log is mostly:
    Executing recipe chrome-pdf

    Sometimes I get one more row:
    Converting with chrome HeadlessChrome/102.0.5005.182 using chrome-pool strategy rootId=0p0two50psg6i71, id=0p0two50psg6i71

    I'm on v3.9.0, but I also tried v3.11.2 with the same result.

    All reports worked yesterday. The only thing I can think of as changed would be:

    • maybe Chrome is updated, but I don't recall accepting an update
    • I rebuilt my Docker image, but I have done this frequently without any problems

    I have also tried 3.9.0-full. I have never used this image before, but I thought it was worth a shot if this is a Puppeteer dependency problem. With this image I got into even more trouble:

  • I discovered the culprit.

    I'm on an M2 Mac, so I have to use FROM --platform=linux/amd64 jsreport/jsreport:3.11.2 in my Dockerfile to be able to run the image at AWS.

    When I build a local image for running in my dev-environment I need to use FROM --platform=linux/arm64 jsreport/jsreport:3.11.2.

    I'll have to come up with a solution for differentiating my local builds. Does anyone know if there are ARM containers available at AWS Fargate? It would be best to run exacrly the same image locally and in production at AWS.

  • administrators

    @msageryd yes, for the Apple Silicon hardware there are special steps (options and params for docker), it is described here. i guess it can help you too (personally, i do all my development on macos with Apple Silicon hardware so i was on charge of writing those instructions)

    Does anyone know if there are ARM containers available at AWS Fargate?

    i am not aware if there are ARM containers there, so i am afraid i won't be much help on this point

Log in to reply

Looks like your connection to jsreport forum was lost, please wait while we try to reconnect.